You were never here, you didn't see anything..

Nokia IP-650 and Endian


Recently I had an idea to replace my temporary firewall with a Nokia IP-650. I had read many posts on the internet of people using a Nokia IP-330 with Endian or other *nix based firewall distributions. Since an IP-330 is a bit low powered for me I looked for e higher end piece of gear, enter the IP-650.

A 50 dollar run through ebay landed an IP-650 on my doorstep shipping included. There seems to be little out there on the web about this unit aside from reviews using the default operating system. The internal hardware list was found in a product document I found after a large amount of searching. The system is Intel based hardware using a Pentium III at 450 MHz. It has dual redundant power supplies, multiple expansion slots and a 2u form factor. The motherboard has a full compliment of features under the case to include an additional Intel 10/100 ethernet port, audio I/O ports and USB. On the underside of the board which has the flash ROM is a 44 pin header similar to that used for laptop hard drives.

Inside the IP-650
Inside the IP-650

Since I am fond of Endian Community Edition and it has served me very well this was my target operating system. I searched for several days before deciding to skip finding more documentation and just try to make things happen. Pulling off the case I learned this was not going to be as easy as I had hoped. The system has no IDE interface on the motherboard and will not boot from USB. To make things a bit more complex the system has a flash ROM it boots from which shows up as the primary master IDE device.

Having had to load a drive on a system with limited options before I jumped right in by loading the hard drive in another system. When I moved it in to place in the IP-650 things failed to boot. The flash ROM being ahead of the HD in drive order was enough to hose the grub configuration which was now on the primary slave drive instead of primary master where it was loaded. Loading the hard drive as primary slave fared no better.

Since I had no documentation on the device and nothing else to go on I decided to put some hardware tinkering to the test. Surveying the boards I located one jumper on the flash ROM board. The jumper was not labeled but as it was the system was no use to me so of course I moved the jumper and booted things up, going straight into the BIOS. To my astonishment the laptop drive I had loaded was not the primary master and the flash ROM the primary slave. No joy however as it failed to boot once I exited the BIOS configuration.

The Jumper Location
The Jumper

Since I had moved things all over in trying to load it before I figured one more pass couldn’t hurt. I did a clean install with the hard drive as the primary master in my load system. When I placed it back into the Nokia it again failed to load and be accessible via the web interface on any of the network interfaces.

I was a bit aggravated but it had at least boot. To test things out I put a network card into the load system and loaded it once more. This time I went all the way up to initial configuration using the web interface using the load system. Once the initial configuration was done I move the drive over to the Nokia and to my amazement it came up and the web interface was accessible via the on board Intel ethernet port. Checking the configuration showed the 4 additional interfaces on the expansion card.

Now that the system was loaded and would boot and run fine I needed to find a way to mount the laptop drive in a permanent fashion. One option was to order a drive trey from ebay. The other was to fabricate a bracket that attached to the underside of the flash ROM card. Since a drive trey was about 50 bucks delivered it was out. I could get a whole unit for that cost. I got out the Dremel and some 2.5 to 3.5 drive brackets… With the drive a little bit off of the board I had to run a cable to the drive. Luckily I had a short 50 pin cable used in an old Panasonic Toughbook. The cable is about 2 inches in length and covers the drive jumpers as well as all 44 pins. Worked perfect.

Drive Card Side Shot
The drive mounted
End shot of the drive mounting
Drive mounting end shot

I set up the firewall to operate inside my current network and ran it for a few days. During this time I checked on possible options to upgrade the system to specs that would suit my needs. The processor has a limit around 850 MHz being it is a slot 1 style Pentium III with a 100 MHz bus speed. Also considering the age of the system and dual power supplies it was not going to be cheap on feeding. The best option for me was to not use it. I chalked it up to a learning experience and donated to a gentleman at work who needed a device like that to serve as the firewall for a church he was helping to build.

Have any Question or Comment?

8 comments on “Nokia IP-650 and Endian

Do you have the pictures that belong to this post? I’d like to see what you’re referring to. I have an ip-650 and I am trying to boot without success.
Thanks.

Reply

Manny,

This post originally had images. I migrated the CMS database from one of my older domains. Give me a little time to see if I can get the images fixed.

The short of the load process was to load the hard drive in another computer and complete the basic web setup. I then transferred it over to the Nokia and swapped the jumper on the ROM card.

I no longer have the unit. I have since upgraded to newer hardware and donated this one to a co-worker for use at his church.

Reply
Manny

No problem. I was trying to get things going on my IP650 and I seem to have problems getting it to boot.
I too have loaded the drive on a different machine, then placed it back on the unit but I can’t seem to be able to get it to boot off the drive. It keeps looking at the flash card. Unlike you, my bios drive order did not change after the jumper switch from off to on (or the other way around) – the order stays the same.
Even if I switch the jumper (the one located next to the flash board) it still wants to boot from flash and it hangs or says “No operating system found”.
Unlike you, I have loaded it with pfsense (router/firewall) verion of FreeBSD, but I have used pfSense on several other Nokia units including IP330 and IP530 (which is very similar to 650 by the way). On the 530 it was very simple, by default if the flash is not bootable or nonexistent, it goes straight to the hard drive and it boots from it. No problem there.
The 650 on the other hand is giving me all kinds of grief.
Now I am even trying to figure out how I could eventually load a “boot loader” on the flash and get it to then load my OS from the hard drive. It’s a long shot…
Any ideas, suggestions are welcome at this point.
Thanks again fro your post.

Reply

I am not sure why yours would behave differently. My first thought would be is the HD using the 44 pin connector on the flash card or is it using the official HD caddy? If using the caddy the device order would still be off even with the jumper switched due to the controller being a completely different unit.

If you do have a drive caddy, perhaps you can use a 44 pin adapter and hook an optical drive to the flash card. If you don’t have the caddy that of course isn’t going to work. Just tossing out ideas.

As for getting the boot loader onto the flash, I wager it can be done but I have no idea how. That is something I have never tried since it normally means special file systems and loading procedures. If you choose that path the most I can do is wish you luck, which I am already!

Reply
Manny

Now, that sheds a little more light on my problem.
First of all, my flash board is different than what I see in your pictures. Mine has a removable compact flash type 8Mb card. The jumper in question is still there, but the pins where you connected your drive are on the top side of the board. Yours seem to be on the bottom. Not that it would make a difference…
I do have a hard drive caddy attached to another slot. Honestly I can’t even tell if the 650 turns it on even. Once you place the caddy in, you don’t know what it does. The unit itself is noisy enough to pretty much cover the hdd spinning noise.
One question tough, do you know what type of ribbon cable (44 pin to…mini IDE?) you used to connect the drive to the flash board? I have one that physically fits but the unit doesn’t seem to recognize the drive… Thanks for fixing the pictures, and all of your input. Greatly appreciated !

Reply

The ribbon cable I used was actually from a really old Panasonic laptop I scrapped. It is a 50 pin cable amusingly enough. I have on rare occasion seen a 44 pin online for sale but as noted they are rare.

If your unit has a removable CF type card what are the chances you can load that? If it is a CF I have been able to load one of those using a CF to IDE adapter. Though from the sounds of things your unit would place the HD as the third device. I would guess the flash ROM would be device 1, the CF device 2 and the HD device 3. Not sure how exactly you could push that thing to boot from the third device, and even then you may have to fix the /etc/fstab file and a few other items on the install.

Reply
Manny

Sorry about the long delay. I’ve been sick lately…
Anyway, it turns out my 650 just died or I don’t know what happened to it but it won’t come up anymore. The I turn it on, all LEDs turn on, flash a while then nothing. No beep, no video, dead. I have no idea what happened to it, but anyway, all your help was much appreciated.
I wanted to give this damn thing one more try and now it won’t come up at all.
Thanks again.

Reply

I am truly thankful to the holder of this website who has shared this fantastic article at here. eekdeebdkcceedee

Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

*

This blog is kept spam free by WP-SpamFree.

Most who fail…

Most who fail have yet to really try!